Degraded Performance - Slow Load Times for Some Users
Resolved
Mar 30, 2026 at 7:47pm UTC
Incident Report - Performance Degradation March 30, 2026
On March 30, 2026, between 5:40 AM PST and 9:15 AM PST, Metronome Software experienced degraded performance. During this time, some users encountered significantly slower than normal load times across the platform.
The root cause was an unexpected spike in system activity that exceeded existing infrastructure capacity, resulting in resource constraints across our servers. Recovery began once our engineering team scaled up server compute resources on AWS, with full performance restored at 9:15 AM PST.
At no point during this incident was customer data or system security compromised.
We are reviewing our infrastructure thresholds and monitoring to detect and respond to similar patterns more quickly in the future.
Affected services
Updated
Mar 30, 2026 at 4:45pm UTC
Load times have fully resumed to normal. This issue is now resolved.
Affected services
Updated
Mar 30, 2026 at 4:15pm UTC
A fix has been applied and performance should be improving.
Our engineering team will continue to monitor.
Next update by 9:45 AM PT
Affected services
Updated
Mar 30, 2026 at 3:30pm UTC
Our engineering team has identified the cause and is working on a fix.
All features and data remain unaffected.
Next update by 9:00 AM PST.
Affected services
Created
Mar 30, 2026 at 2:44pm UTC
Some users are experiencing slower than normal load times in Metronome Software.
Our development team is actively investigating.
All features remain accessible.
Next update by 8:30 AM PST.
Affected services