Back to overview
Degraded

Partial Outage - Login Issue Affecting Multiple Users

Mar 16, 2026 at 02:06pm UTC
Affected services
metronomesoftware.com

Resolved
Mar 16, 2026 at 03:27pm UTC

Resolved

The login issue affecting Metronome Software has been resolved. Full access has been restored for all users.

If you are still experiencing issues, please submit a support ticket at support@metronomegrowthsystems.com and our team will follow up with you directly.

Thank you for your patience.

Created
Mar 16, 2026 at 02:06pm UTC

Metronome Software is currently experiencing a login issue affecting multiple users across all browsers. Users may be unable to access the platform.

Our engineering team has identified the issue and is working to restore full access. We will post updates every 30 minutes until resolved.

We sincerely apologize for the impact to your work.